Installing SOA 11gR1 with Oracle XE

So you are about to install SOA Suite 11gR1? Congratulations, you are starting an exciting journey, one which will reveal many new and wondrous sights along the way. But before you begin, don’t you want to know the answer to the number one question that comes up during installation?

When you choose Oracle XE as your database server, you get a warning message that you need a newer database version. This is because Oracle XE is version 10.2.0.1 and SOA Suite 11gR1 requires Oracle 10.2.0.4 or higher or 11.1.0.7 or higher. However, this warning is for production installs only and for a development install, you can ignore the warning.

Oracle XE is a fine choice for a small-footprint database for developing on SOA Suite 11gR1. Ignore the warning!

Comments:

It ill be good to have this information documented in install guide, I have been strugglng with my database to get a clean install of SOA suite and could have saved some time with this information

Posted by Varsha on July 23, 2009 at 04:20 PM PDT #

Yes, we'll try to add this to the next revision of the doc. Thanks for the feedback!

Posted by Demed on July 28, 2009 at 07:51 AM PDT #

hi please send dump of Soa Server 11g+jdev 11g to my mail

Posted by praneeth on July 28, 2009 at 04:46 PM PDT #

I'm unable to download SOA Suite 11g "ofm_soa_generic_11.1.1.1.0_disk1_1of1.zip" from downloads. Can you please suggest me an alternative site for downloading SOA Suite.

Posted by Chandrakanth Belde on September 22, 2009 at 01:07 AM PDT #

What do you mean by unable? Let me know what happens when you try to download so I can get it fixed. Heidi.

Posted by heidi.buelow on September 22, 2009 at 01:26 AM PDT #

I had to increase some of the resource limits in oracle XE to pass some of the prereq checks doing: ALTER SYSTEM SET PROCESSES=500 SCOPE=SPFILE; ALTER SYSTEM SET OPEN_CURSORS=500 SCOPE=BOTH; SHUTDOWN STARTUP

Posted by James Kao on October 21, 2009 at 02:05 AM PDT #

This is expected. If you only install SOA Suite, you need >= 200 processes. If you install all selections, you need >= 500 processes. The error message during installation lets you know how many you need.

Posted by heidi.buelow on October 26, 2009 at 12:13 AM PDT #

Is it absolutely necessary to use Oracle Database 10g Express Edition Universal as mentioned in the the hands-on tutorial? Which problems can you expect when using Western European edition?

Posted by Sjoerd Aalbers on November 09, 2009 at 04:57 PM PST #

We have seen errors when you do not use the universal version of XE. I haven't tried it with the GA version though! Let us know what happens. Heidi.

Posted by heidi.buelow on November 11, 2009 at 05:03 AM PST #

I tried install SOA with Oracle XE as DB in Ubuntu. However, when doing the prereq check, its failing with an error that Oracle JVM is not installed. I understand that Oracle JVM is not part of Oracle XE, but is there a work around? Please advise. Vivek

Posted by Vivek on December 02, 2009 at 09:33 AM PST #

Vivek - (sorry for the late reply; found a bunch of unapproved comments that we had missed...) What part is failing - XE install, WLS install, SOA install or SOA config? And what is the exact error message (I don't recall anything about an "Oracle JVM")? Thanks.

Posted by Demed L'Her on February 04, 2010 at 12:48 AM PST #

i want to install SOA with using of XML Schemas please give an information please send me the detalis please

Posted by guest on October 07, 2011 at 06:07 PM PDT #

Post a Comment:
  • HTML Syntax: NOT allowed
About

Find Us on facebook Follow us on twitter Oracle SOA Suite forum
SOA PM team
Welcome to the Oracle SOA Suite team blog. We'll use this site for news and information that did not make it into our official documentation for a reason or another.

Search

Archives
« April 2014
SunMonTueWedThuFriSat
  
1
4
5
6
8
9
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
   
       
Today