Timeout error starting OHS with OAM WebGates on Oracle Solaris (SPARC)

Oracle Access Manager provides single sign-on (SSO), authentication, authorization, and other services to registered agents (in any combination) protecting WebCenter resources. A Web server, Application Server, or any third-party application must be protected by a WebGate or mod_osso instance that is registered with Oracle Access Manager as an agent to enforce policies. The agent acts as a filter for HTTP requests.

This document relates to the following versions of the products:

  • Oracle Web Tier Utilities: 11.1.1.7.0
  • OAM WebGates for OHS: 11.1.2.1.0

When you try to install and configure Oracle Web Tier Utilities with Oracle OAM WebGates for OHS on Oracle SuperCluster (or Solaris SPARC), the installation and initial configuration may go fine in the beginning. However, once you start putting in your directives for OAM protected resources, you may notice that the OHS component does not start up as it used to.

The opmnctl startall and opmnctl stopall commands take longer than usual with the following error messages. You may also notice that the OHS and OPMN log files do not contain much information.

  user1@hostname1:~$ /u01/oracle/ohs_inst/ohs_server02/bin/opmnctl startall

  opmnctl startall: starting opmn and all managed processes...

  =============================================================================

  opmn id=hostname1:6701

  Response: 0 of 1 processes started.

  ias-instance id=ohs_server02

  +++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

  -----------------------------------------------------------------------------

  ias-component/process-type/process-set:

  ohs2/OHS/OHS/

  Error

  --> Process (index=1,uid=118965811,pid=13118)

  time out while waiting for a managed process to start

  Log:

  /u01/oracle/ohs_inst/ohs_server02/diagnostics/logs/OHS/ohs2/console~OHS~1.log

The culprit is the webgate.conf include in the httpd.conf file and removing it will resolve the issue. However, now you cannot use OAM for SSO.

You may want to try out the steps in MOS Note 1614464.1 to edit the webgate.so file; but this may not resolve the issue. I was able to start the OHS server after modifying the webgate.so file, but got a blank (empty) response when I tried to access the application URLs. I would suggest that you read through the rest of the blog and try the solution below.

The fix to this problem is to add the following entry, where IP_Address is the IP address of the local machine, in /etc/hosts on which Oracle HTTP Server is being installed:

IP_ADDRESS stafas12

Yes, you need to put in this value which may be entirely unrelated to you network configuration into the /etc/hosts file to fix the issue.

You can refer to page 57 in the Oracle Fusion Application Release Notes 11.1.7 in MOS Note 1582125.1 for more details. This document also contains the list of other known issues and their resolutions.

Comments:

Post a Comment:
  • HTML Syntax: NOT allowed
About

Welcome to my blog. I use this site to share my experience as well as tips and tricks on Oracle Fusion Middleware products.

Contributors

Search

Archives
« July 2015
SunMonTueWedThuFriSat
   
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
18
19
20
21
22
23
24
25
26
28
29
30
31
 
       
Today