Thursday May 06, 2010

Updating EclipseLink to a newer version in existing GlassFish V3 installation

GlassFish V3 ships with EclipseLink 2.0 binaries as JPA provider. If you need to update your existing GlassFish installation to a newer version of EclipseLink binaries, you will need to do following



  • Download newer version of EclipseLink binaries from http://www.eclipse.org/eclipselink/downloads/. Choose OSGI bundles from the available downloads

  • Replace following files under $GLASSFISH_HOME/glassfish/modules with corresponding jars you downloaded above


    • org.eclipse.persistence.antlr.jar

    • org.eclipse.persistence.jpa.jar

    • org.eclipse.persistence.asm.jar

    • org.eclipse.persistence.jpa.modelgen.jar

    • org.eclipse.persistence.core.jar

    • org.eclipse.persistence.oracle.jar

    • javax.persistence.jar


  • Restart GlassFish

Monday Mar 02, 2009

Using Hibernate as JPA Provider for GlassFish V3

GlassFish V3 prelude ships with EclipseLink as the default JPA provider. The question that frequently gets asked is: How hard it is to to use Hibernate as the persistence provider with Glassfish V3. The answer is:  Not at all :). It is even simpler to achieve this than it was with V2. Thanks to the wonderful V3 update center it is as easy as 1-2-3. Lets  walk through the steps:

1. Download and install GlassFish V3 prelude with update tool.

2.  Launch the update tool. Hibernate is available under "Available Add-ons" as can be seen below. Check "Hibernate JPA" and click install.


3. GlassFish will be ready to use Hibernate as JPA provider[1]. The file <installdir>/hibernate/overview.txt contains all the information to get you started.

[1] Please note that we had used Derby 10.4.2.1 (also available with the update tool) for testing.


About

Mitesh Meswani

Search

Categories
Archives
« April 2014
SunMonTueWedThuFriSat
  
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
   
       
Today
Bookmarks